Superuser Update Fixer v1.2 apk

Requirements: ANDROID:1.5 and up

Overview: This app is designed to fix update problems that come from mismatched 
signatures between Superuser.apk on your phone, and Superuser.apk on the Market. If successful, 
this app will let you update 
from the market even if you've had trouble before.

** Requires root **

Note: This app requires busybox. A static build of busybox is included in the app,
but is only used if you do not have busybox already installed. The included version 
should work on most phones. If it does not work for you, please email me at the link
below so we can get it working.

What's New:
Bundled busybox to ensure widest compatibility
Streamlined fix process

More Info:
Download Instructions:


Read more:


Our Partners